ホーム > カテゴリ > Ruby・Ruby on Rails >

Vue.jsをIE11に対応させる [Rails6]

Vue.jsをIE11に対応させるには「babel-polyfill」をインストールします。サーバーとの通信でFetch APIを使用する場合は「fetch-polyfill」です。

babel-polyfill

次のコマンドを実行する。

yarn add babel-polyfill

babel-polyfillはVue.jsをインポートする前にインポート宣言を行います。

import "babel-polyfill";
import Vue from 'vue'
import App from '../app.vue'

fetch-polyfill

IE11でFetch APIを使用する場合は、このコマンドを実行する。

yarn add fetch-polyfill

.jsまたは.vueファイル側でのインポート宣言

import "fetch-polyfill";

パッケージの削除

yarn remove パッケージ名






関連記事



公開日:2020年03月14日 最終更新日:2020年03月17日
記事NO:02822